Ticket #288 (closed defect: fixed)

Opened 13 years ago

Last modified 13 years ago

Java exceptions during the record-and-playback phase

Reported by: kmaclean Owned by: kmaclean
Priority: minor Milestone: SpeechSubmission 0.1.1
Component: SpeechSubmission Version: SpeechSubmission 0.1
Keywords: Cc:

Description (last modified by kmaclean) (diff)

From David Gelbart:

I have seen some Java exceptions during the record-and-playback phase but I haven't figured out how to reproduce them. Strangely, the submission application seems unaffected by the exceptions.

Change History

comment:1 Changed 13 years ago by kmaclean

  • Description modified (diff)

Here is one log snippet:

Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0400.wav
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0401.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0401.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0401.wav
Exception in thread "Capture" java.lang.NullPointerException
       at
speechrecorder.CapturePlayback$Capture.run(CapturePlayback.java:1961)
       at java.lang.Thread.run(Unknown Source)
numPeakValues: 11
proportionPeakValues: 8.333333E-5
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0401.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0401.wav
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file

Another log snippet with several exceptions in it:

Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0415.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0415.wav
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0416.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0416.wav
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0417.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0417.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0418.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0418.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0419.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0419.wav
numPeakValues: 50
proportionPeakValues: 4.1666668E-4
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0420.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0420.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0420.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0420.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0421.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0421.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0422.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0422.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0423.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0423.wav
numPeakValues: 0
proportionPeakValues: 0.0
Capture uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0424.wav
TargetDataLine allocated has this AudioFormat: PCM_SIGNED 48000.0 Hz,
16 bit, mono, 2 bytes/frame, little-endian
Capture.run uploadWavFile
is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0424.wav
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
Error during playback: java.io.IOException: Stream closed
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file
Exception in thread "Playback" java.lang.NullPointerException
       at
speechrecorder.CapturePlayback$Playback.run(CapturePlayback.java:1820)
       at java.lang.Thread.run(Unknown Source)
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
Error during playback: java.io.IOException: Stream closed
reached end of file
Error during playback: java.lang.NullPointerException
Exception in thread "Playback" java.lang.NullPointerException
       at
speechrecorder.CapturePlayback$Playback.run(CapturePlayback.java:1820)
       at java.lang.Thread.run(Unknown Source)
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file
Temp Speex file: C:\DOCUME~1\David\LOCALS~1\Temp\mdl62791.spx
Destination URL is http://read.voxforge1.org/javaUploadServer.php
Adding b0415.wav
Adding b0416.wav
Adding b0417.wav
Adding b0418.wav
Adding b0419.wav
Adding b0420.wav
Adding b0421.wav
Adding b0422.wav
Adding b0423.wav
Adding b0424.wav

comment:2 Changed 13 years ago by kmaclean

  • Milestone changed from SpeechSubmission 0.1.3 to SpeechSubmission 0.1.2

comment:3 Changed 13 years ago by kmaclean

CapturePlayback.java:1961

Error:

is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62775.tmp\a0401.wav
Exception in thread "Capture" java.lang.NullPointerException
       at
speechrecorder.CapturePlayback$Capture.run('''CapturePlayback.java:1961''')
       at java.lang.Thread.run(Unknown Source)
numPeakValues: 11
proportionPeakValues: 8.333333E-5

Code:

    /** 
     * Reads data from the input channel and writes to the output stream
     */
    class Capture implements Runnable {
        [...]
        public void run() {
            [...]
1961        line.close();
            [...]

comment:4 Changed 13 years ago by kmaclean

CapturePlayback.java:1820

error:

is:C:\DOCUME~1\David\LOCALS~1\Temp\VF-dir62789.tmp\b0424.wav
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
numPeakValues: 0
proportionPeakValues: 0.0
calling getAudioInputStream from Capture
Error during playback: java.io.IOException: Stream closed
numPeakValues: 0
proportionPeakValues: 0.0
reached end of file
Exception in thread "Playback" java.lang.NullPointerException
       at
speechrecorder.CapturePlayback$Playback.run(CapturePlayback.java:1820)
       at java.lang.Thread.run(Unknown Source)
calling getAudioInputStream from Capture

code

    /**
     * Write data to the OutputChannel.
     */
    public class Playback implements Runnable {
        public void run() {
1820        line.stop();

comment:5 Changed 13 years ago by kmaclean

CapturePlayback.java:1820 - CapturePlayback.java:1820

can reproduce this error if you press Play and Stop multiple times in a row ... very quickly. Seems like Java JVM simply cannot keep up with multiple Play/Stop? commands in a row.

comment:6 Changed 13 years ago by kmaclean

CapturePlayback.java:1961

can't reproduce this error ... might have been cleaned up with the removal of legacy MoodleSpeex? code (i.e Speex encoding and decoding code)

comment:7 Changed 13 years ago by kmaclean

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.