Ticket #264 (closed enhancement: fixed)

Opened 12 years ago

Last modified 12 years ago

Change from AssetProxy to Applet in HTML

Reported by: kmaclean Owned by: kmaclean
Priority: major Milestone: SpeechSubmission 0.1.1
Component: SpeechSubmission Version: SpeechSubmission 0.1
Keywords: Cc:

Description

Currently, the SpeechSubmissions? applet is run using WebGUI's AssetProxy?. Change so that applet call is in a WebGUI page, that way, the user's browser will get the the SpeechSubmisson? Applet directly from 1&1 rather than from VoxForge? WebGUI cache

Change History

comment:1 Changed 12 years ago by kmaclean

  • Milestone changed from SpeechSubmission 0.1.3 to SpeechSubmission 0.1.2

comment:2 Changed 12 years ago by kmaclean

Does not seem like the SpeechSubmission.jar file is being passed through the WebGUI server.

The WebGUI "proxy webobject" incorporates the SpeechSubmission.php page in the browser, so it looks like the the content of the php page are incorporated into the WebGUI page. But the display of source in the browser shows the links pointing to voxforge1.org.

comment:3 Changed 12 years ago by kmaclean

  • Status changed from new to closed
  • Resolution set to fixed

Confirmed with Etherape, and

  • clear the JVM applet cache: for Ubuntu 6, delete the SpeechSubmission.jar from the user's Java cache in home/username/.java/deployment/cache/javapi/v1.0/jar
  • restart the browser to clear the browser cache
  • go to applet page and watch Etherape ... largest download occurs from perfora.net (i.e. www.voxforge1.org)

Therefore can still use WebGUI web proxy weboject for the SpeechSubmission app.

Note: See TracTickets for help on using tickets.